Saturday, November 21, 2009

Inside the Prophet 08

Before you look at me like I am a crazy person, here's what happened : the early batch of Prophets was shipped with a set of faulty encoders, that tend to increase the value when you turn the knob counterclockwise too fast.
The issue took more than a year to develop with mine, but there it was.
I've contacted Dave Smith's support and they immediately sent me the Deoxit contact cleaner that you need to fix the problem, along with instructions.
Here's the official page about the issue : DSI Support

And first, you got to remove all encoders. Just pull them straight up, not too hard, and don't let the cat play with them. Trust me. You don't want that to happen.


Then, remove all screws on the top of the panel, and on the back of the panel.

If you pull up the panel, you'll see that it's connected with two ribbon cables to the main part of the instrument, and another cable connecting the Pitch and Mod wheels.
Unplug these three and take the whole panel away.


On the panel, carefully remove the screws that tie up the boards.

Now, you've got your board.


Put the Deoxit, one drop at a time, here in the little crack :


Repeat the operation three times, while moving the boards around to distribute the liquid.

Pull the whole shebang back together and encoders should work fine.

6 comments:

kame said...

"and don't let the cat play with them"

Quelle idée d'avoir un chat aussi !

khoral said...

Parce que ça rend la maintenance beaucoup plus vivante.

Philippe said...

Bonjour,

Je me demande si je n'ai pas le même problème.

Quand je tourne certains encodeurs (j'en ai peu finalement car j'ai la version Prophet 08 PE avec potentiomètres), je constate souvent un problème de précision qui devient très aléatoire suivant la vitesse à laquelle je tourne les encodeurs. Soit les valeurs augmentent alors que je suis entrain de tourner dans le sens contraire ou bien elles diminuent alors que je tourne dans le sens des aiguilles d'une montre !! Parfois les valeurs sautent ou font une espèce de "sur-place" du genre : 97-98-99-100-99-98-99-97-100.... Ca peut vite devenir très énervant ! Je précise que je n'ai aucun problème avec les potentiomètres qui sont bien plus performants que les encodeurs.

As-tu eu le même genre de soucis que moi et est-ce que cette manipulation résout-elle réellement tous ces problèmes ?

J'ai échangé plusieurs mails avec une certaine Tracy de DSI mais elle est restée très évasive dans ses réponses et ne m'a pas réellement aidé...

Merci de ton aide (et bravo au passage pour ton blog & ta musique) ;-)

khoral said...

C'est exactement le problème, et après manipulation, le problème semble avoir disparu, à l'exception d'un encodeur particulier, très "dur", qui continue à faire des siennes... il faudra que je répète la manip avec celui-là.

Pour Tracy, ça m'étonne un peu, elle m'a directement envoyé un flacon de Deoxit, puis un email expliquant le problème et la procédure.
Je te conseille de réessayer, c'est bizarre qu'il y ait eu deux réactions si différentes...

Merci!

Philippe said...

OK merci pour ta réponse.

Je vais recontacter Tracy. Est-ce que je peux me permettre de lui envoyer l'article de ton blog qui décrit très bien le problème (ton anglais est meilleur que le mien...!!!) comme ça j'aurai un argument supplémentaire pour l'envoi du produit ?

khoral said...

Bien sûr, pas de problème.